Google Vehicle Ads Setup

Below you will find a quick set-up guide we have put together for you. Our apologies in advance as some steps aren't fully documented as they require active Websites and Merchant Center Accounts but we hope this will give you a solid foundation to get your first campaign up and running. Feel free to download the presentation and share it with your team.

***Please note at this time, it does appear Google does have to whitelist the Merchant Center account so the “Vehicle Ads” option is available. Should you get to that step in the process and only see an option for Shopping Ads, you will need to contact your Google Rep so the account can be enabled for Vehicle Ads.

Please review the list of errors below. These are errors within the dealer inventory and Hoot holds no responsibility for accuracy or issues related to inventory uploads because of these errors. Google does not remove duplicate vins or clear previous issues upon upload. Should you have issues uploading it is recommended you remove all previous product prior to re-uploading so you are looking at relevant error messages.

Here are some of the common errors:

  • Dealer Image Overlays

    • Best practice inform the dealership overlays are not allowed through the Merchant Center feeds

    • Ask dealership to remove overlays from the second image of the each vehicle, while ensuring that image is a front facade of the vehicle

    • Review the images from the feed link prior to uploading

  • GMB Store Code Errors:

    • Review to make sure GBP (Google Business Profile) is linked in Merchant Center, and the dealer listing is in the MC linked account and the relevant Business Group is linked as well

    • Review to make sure there is a store_code attribute in the VLA feed

    • Review to make sure there is a Store Code in the GMB listing

    • Review to make sure the VLA feed store_code matches the GMB listing Store Code

    • Make sure that there are no pending updates to the address in GMB

    • Uncommon: make sure the store_code doesn't have a lead '0' (eg 08662) (note there's a temporary issue with we can't ingest a store_code with a leading '0', so recommendation is to remove the leading '0')

  • Missing Color

    • This error is common if you wish to filter out vehicles with no color listed please do so in the feed filters

  • Missing Mileage

    • This error is common if you wish to filter out vehicles with no mileage listed please do so in the feed filters

  • New Car Mileage over 200 miles

    • This error is common if you wish to filter out new vehicles with over 200 miles listed please do so in the feed filters

  • Missing Price

    • This error is common if you wish to filter out vehicles with price listed please do so in the feed filters

  • Incorrectly appending Value-track store code parameter {store_code} see here for implementation

  • Please see the set-up guide for additional errors and how to handle these.